PayPal: Migration from PrestaShop 1.6 to PrestaShop 1.7

This article is created in order to help you if you want to do a PayPal module migration, from PrestaShop version 1.6 to PrestaShop 1.7.

Please pay attention that PrestaShop 1.6 and PrestaShop 1.7 have different versions of our module. 

You can not use the version 3.x of PayPal module on PrestaShop 1.7. The core of PrestaShop 1.6 and 1.7 is very different. So, PayPal has one version of the module for PS.1.6.x (v3.x) and another one for PS1.7 (v5.x).

It is not possible to use PayPal v3.x on PrestaShop 1.7 (and so it is impossible to update the module from 3.x to 5.x).

If you have errors related to errors like (The controller AdminPayPalSetup is missing or invalid) or others, this is the procedure you must follow in order to correctly install the module on your site:

You have to uninstall the v3.x before migrating to PrestaShop1.7 (the details about previously created orders will be saved)

Once the migration to PrestaShop 1.7 is done you have to install and configure the v5.x of PayPal module.

If you have any questions, do not hesitate to contact us directly in the addons chat here: https://addons.prestashop.com/fr/contactez-nous?id_product=1748